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A l'origine, la vocation de Maple est d'être un logiciel de calcul formel. Au fur et à mesure des 
versions, le logiciel a offert une gamme de possibilités typographiques de plus en plus large afin que
les utilisateurs puissent documenter leur travail par du texte. A dire vrai, le traitement de texte reste 
insuffisant si on le compare sur ce point avec des logiciels dédiés. Il n'en reste pas moins qu'une 
feuille de travail Maple (en anglais : worksheet) est désormais comparable à un article ou un 
chapitre structuré en sections composées d'un entrelacement de paragraphes littéraires, de groupes 
de commandes informatiques et de "sorties" (expressions, équations, graphiques, etc...)
Ce chapitre expose les bases de la structuration d'un worksheet.

Worksheet Mode versus Document Mode
Lors de sa première utilisation, Maple démarre par défaut en lançant une feuille de travail du 
type Document Mode. Apparemment, l'équipe des concepteurs mise beaucoup sur cette 
présentation documentaire, tenue pour conviviale, esthétique, ludique, bref agréable. Elle souffre
cependant de deux défauts : les commandes mathématiques y sont moins rigoureuses que dans le
mode worksheet; l'édition reste bien moins attractive qu'un logiciel dédié du type LaTeX ou 
même Word. C'est pourquoi nous conseillons de travailler systématiquement dans le Worksheet 
Mode, qui est rigoureux (et même intraitable) sur le plan du formalisme mathématique et 
informatique et se cantonne modestement mais efficacement dans l'édition basique. Tous les 
chapitres de cet ouvrage ont été rédigés dans ce mode et personne ne s'est plaint de difficultés de 
lecture jusqu'ici.
Pour paramétrer définitivement une version Maple en mode Worksheet, il faut procéder aux 
manipulations suivantes :

Dans la barre d'outils, cliquer sur Tools, puis Options pour faire apparaître le menu suivant :
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2. Cliquer sur l'onglet Interface et choisir Worksheet (en lieu et place de Document) sur la ligne 
Default format for new worksheets :
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3. Cliquer ensuite sur l'onglet Display et choisir Maple Notation sur la ligne Input display puis 2-
D Math Notation sur la ligne Output Display :
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4. Valider ces choix en cliquant sur Apply Globally. 
Désormais, tous les nouveaux documents de travail seront ouverts par défaut dans le mode 
Worksheet. Les commandes informatiques seront écrites en police monospaced 12 points de 
couleur rouge alors que les sorties seront affichées en Times New Roman 12 points de couleur 
bleue (à l'exception des messages d'avertissement, écrits en police monospaced). Le texte sera en
Times New Roman 12 points de couleur noire.

Partitionnement de la feuille de travail
Généralement, une feuille de travail est structurée en plusieurs sections, chacune pouvant 
comprendre des sous-sections, voire des sous-sous sections, des sous-sous-sous sections ...
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Deux cas se présentent : l'auteur connaît exactement le plan de la feuille au démarrage ou, au 
contraire, il structure sa feuille au fur et à mesure de l'avancement du travail.

Le plan est connu a priori
Soit le plan d'étude fictif suivant :

Introduction
Forme structurelle du modèle
Forme réduite du modèle
Statique comparative
Effets des modifications de valeur des paramètres
Conclusion
Références bibliographiques
Annexes

A l'ouverture de la feuille en mode Worksheet, Maple attend une instruction informatique par
défaut, qui est signalée par un prompteur rouge placé à droite d'un crochet. En cliquant dans 
le menu Insert sur Section, on voit apparaître automatiquement sous le prompteur un triangle 
grisé dont la pointe du bas est prolongée par une ligne brisée menant vers un crochet 
contenant un prompteur rouge. Dans la première cartouche du menu contextuel, le style de 
paragraphe a basculé sur P (comme paragraphe) Heading 1 (comme Section de niveau 1). La 
barre d'insertion clignote à droite du triangle : elle attend en mode texte le titre de la section.

On frappe Introduction pour obtenir le titre de la section en police Serif corps gras de taille 18
:
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Les sections suivantes sont formées suivant le même principe, c'est à dire en cliquant à 
chaque fois sur Section dans le menu Insert et en frappant le titre. A la fin, on obtient la 
présentation suivante :

6



Passons à la question des sous-sections. Supposons que la section Statique comparative soit 
divisée en 3 sous-sections :
1. Politique budgétaire
2. Politique fiscale
3. Politique monétaire
Après avoir calé le point d'insertion après le prompteur rouge sous le titre de la section, 
on clique sur Subsection du menu Insert. Apparaît aussitôt un triangle grisé prolongé par une 
ligne menant à un crochet et un nouveau prompteur décalé vers la droite. Le menu contextuel 
a basculé sur Heading 2 et éditera du texte en Serif gras16 points, ce qu'on vérifie en tapant 
Politique budgétaire.

Pour positionner la sous-section suivante, on doit à nouveau se placer après le prompteur et 
aller dans le menu Insert mais, contrairement à la manipulation précédente, on ne clique pas 
sur Subsection mais sur Section. En effet, on veut créer une section de même rang que 
Politique budgétaire, soit un Heading 2, et non une section de rang inférieur qui serait un 
Heading 3. On tape Politique fiscale et on procède semblablement pour la sous section 
Politique monétaire. Le résultat donne :
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Avec les mêmes principes, il est possible de créer des sous-sous sections (Heading 3) et des 
sous-sous-sous sections (Heading 4) et même des sections de niveau encore plus faible (qui 
resteront typographiées comme des Heading 4). Par exemple :
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Toute feuille de travail prend vite des proportions importantes qui sont nuisibles à la lisibilité 
de l'ensemble. C'est normal car toute l'étude est contenue sur une feuille et une seule et il faut 
faire défiler plusieurs "pages" d'écran - souvent au petit bonheur - pour trouver une 
information précise ou simplement pour dominer la structure du worksheet. Pour pallier cette 
gêne, les concepteurs ont muni les sections d'une propriété dynamique fort judicieuse : toute 
section générale ou section de niveau inférieur est "rétractable" et "développable" à la 
demande. Dès qu'une partie de document est annoncée comme section ou sous-section, elle 
est cachée ou pleinement accessible en cliquant sur le triangle grisé situé avant le titre : un
triangle prolongé d'un crochet présente le contenu de la section; un triangle fléchant vers la 
droite cache le texte et les instructions. Par exemple, pour connaître le plan général de la 
feuille, il suffit de cliquer sur tous les triangles situés en face des titres de sections :
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Structuration progressive
Si on ne connait pas la structure finale du document, la composition se fait au fur et à mesure 
de l'avancement du travail. Passer d'un thème à un autre signifie qu'il faut transformer ce qui 
précède en section (ou sous section) au moyen de la commande Indent du menu Format. 
L'exemple suivant montre comment procéder. Partons de la feuille -bien mince en vérité - 
dans laquelle sont nettement séparés les paragraphes texte et mathématiques A et les 
paragraphes B :

Pour réunir les paragraphes de type A dans une même section, il faut les sélectionner avec la 
souris (ce qui surligne leur contenu en bleu) puis valider Indent dans le menu Format. Une 
section contenant les paragraphes est automatiquement créée et on peut aisément lui donner 
un titre. On aura :
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Pour diviser le contenu d'une section en sous sections, le principe est le même : sélectionner 
les paragraphes devant faire partie du même groupe, puis invoquer Indent. Dans l'exemple, en
opérant de cette manière sur les deux premiers paragraphes puis sur les deux derniers, le 
résultat est :
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On peut naturellement, en fonction des besoins, créer des sous-sous sections, des sous-sous-
sous sections, etc... Le résultat final est une succession de parties ayant les mêmes propriétés 
que celles vues dans le cas où l'utilisateur connaît a priori la structure de sa feuille de travail, 
en particulier la possibilité de compacter ou décompacter le plan. 
Dernier point. Il peut arriver qu'on éprouve des remords sur la structure finale de la feuille. 
En particulier, on peut estimer que deux ou plusieurs sections d'un même niveau méritent 
d'être réestimées et placées à un niveau supérieur. Par exemple, les sous sections A1 et A2 
devraient devenir des sections en tant que telles et ne plus être réunies au sein de la section A.
Après avoir sélectionné ces deux sous sections, on clique sur la commande Outdent du menu 
Format pour obtenir deux nouvelles sections (et, du coup, la section A disparaît) :

En cas de repentir immédiat, on peut toujours revenir en arrière en cliquant sur le bouton 

Undo the last operation de la barre des tâches (c'est à dire ). Si le repentir est tardif, on 

recommence les manipulations ... Enfin, si le repentir est tel qu'il remet en cause l'existence 
même d'une section ou d'une sous section, il ne faut pas hésiter à la supprimer en plaçant le 
curseur en fin de titre puis en appuyant sur la combinaison de touches Ctrl + Supp. C'est 
radical : tout disparaît, le titre et le contenu de la section.

Indications typographiques
Une feuille de travail est structurée en sections de plusieurs niveaux de profondeur. Toute partie 
est formée d'une succession de paragraphes divisés en deux types : des inputs Maple et du texte 
mélangeant, si besoin est, des caractères alphabétiques et des expressions mathématiques. Cette 
section donne quelques indications sur leur composition typographiques.

Inputs Maple
Un input est formé d'une ou de plusieurs instructions informatiques au moyen d'une syntaxe 
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précise afin d'obtenir une réponse (un output) à un problème de nature mathématique. Il 
démarre toujours après un prompteur rouge  , présent par défaut à l'ouverture d'une 

session ou provoqué en cours de session en cliquant sur le logo    dans la barre des 

tâches.
Dans la syntaxe Maple, une instruction se clôt obligatoirement par un "point-virgule" si on 
veut faire apparaître l'output ou un "deux points" si on veut empêcher l'affichage de l'output. 
Elle est validée en frappant la touche Return du clavier. Après validation, un paragraphe 
contenant une seule instruction aura donc l'aspect suivant :

Mais un paragraphe peut contenir plusieurs instructions. Une bonne habitude consiste à 
réserver une ligne par instruction et une seule. Au cours de la frappe, on passe d'une ligne 
à la suivante en tapant la combinaison de touches Majuscule (Shift)+Enter (et non 
Majuscule seulement, qui est utilisée pour la validation informatique de l'instruction). Dans 
l'exemple suivant, le paragraphe a 3 lignes d'instructions, chacune se terminant par un point-
virgule (ce qui affiche le résultat). Les commentaires situés immédiatement à droite du dièse 
(#) ne sont pas lus par le logiciel.

On doit aussi faire mention du cas particulier des programmes informatiques qui contiennent 
jusqu'à plusieurs dizaines de lignes et dont on accroît la lisibilité en tabulant les groupes 
d'instructions cohérents. Cela donne :
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Sur le plan purement typographique, il n'y a pas grand chose à dire ou ajouter sur les inputs 
Maple. On peut les paramétrer autrement dans Tools → Options ou encore modifier l'allure 
des caractères dans le menu contextuel, mais c'est sans aucun intérêt.

Composition des textes
Les parties textuelles d'une feuille de travail sont nettement distinctes des inputs. Leur 
composition se fait en mode texte auquel on accède par deux moyens :

On transforme un input vide existant en plaçant le curseur après le prompteur puis en 
exécutant la compinaison de touches Ctrl + Majuscule (Shift) + t. Le prompteur disparaît
et le curseur attend la frappe d'un texte comme on le voit dans le menu contextuel qui a 
basculé sur C text. Le même résultat est obtenu en plaçant le curseur après le prompteur 
puis en invoquant Insert → Text. En pratique, le raccourci clavier est plus utilisé parce 
que plus rapide.

On crée un nouveau paragraphe textuel en cliquant sur le logo  dans la barre des 

tâches. Ainsi, pour séparer deux paragraphes textuels, il suffit de cliquer sur  à la 

fin du premier.
Par défaut, un paragraphe textuel est bordé à gauche par un crochet qui s'allonge au fir et à 
mesure que les lignes se remplissent. Certains auteurs suppriment le crochet, soit localement 
en sélectionnant les lignes du paragraphes et en cliquant sur Format→Create Document 
Block (l'opération inverse se fait par Format→Remove Document Block), soit globalement et
durablement en décochant à l'ouverture du worksheet l'option Bracket Matching dans 
Tools→Options→Interface puis en validant ce choix par Apply to Session (l'option est 
valable pour le worksheet en cours) ou Apply locally (l'option est retenue par défaut pour 
tous les worksheets à venir).
A l'intérieur d'un paragraphe textuel, on peut scinder le texte en sous-paragraphes en allant à 
la ligne comme on le fait avec n'importe quel traitement de texte, c'est à dire par la touche 
Enter. Avec la même touche, on insère des lignes vides pour aérer le paragraphe.
Le mode texte permet évidemment d'écrire du texte pur avec des options peu nombreuses en 
Maple mais cependant réelles. Il tolère aussi un mélange de texte pur et d'expressions 
mathématiques, ce qui est la moindre des choses pour un logiciel de calcul formel.
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Edition d'un texte "pur"
Par défaut, une cellule de texte est paramétrée pour accepter des caractères en Times New 
Roman 12 points corps maigre sur une ligne justifiée à gauche. La barre contextuelle se 
présente alors comme suit :

On voit que la barre contextuelle propose d'autres paramétrages.
Commençons par les dix logos les plus à droite.
Tout caractère ou groupe de caractères sélectionnés en les surlignant par le curseur 
devient gras en cliquant sur le logo Bold (  ) dont le raccourci clavier est Ctrl + b, 

passe en italique en cliquant sur le logo I (  ) dont le raccourci clavier est Ctrl + i, se 

souligne en cliquant sur le logo "Underlined" (  ) dont le raccourci clavier est Ctrl + 

u.

Une fois sélectionnée, une ligne se justifie à gauche (  ), au milieu (  ) ou à 

droite (  ) ; Maple n'offre pas la possibilité de justifier à gauche et à droite.

Un caractère ou un groupe de caractères se colorie en cliquant sur le logo  puis en 

choisissant une couleur dans la palette proposée.
Un caractère ou un groupe de caractères se surligne en cliquant sur le logo   puis en 

choisissant une couleur dans la palette proposée.
L'initialisation d'une liste à pastilles se fait en cliquant sur le logo   . A chaque 

passage à la ligne, une nouvelle pastille est créée. Pour arrêter la liste, il suffit de recliquer
sur le logo.
L'initialisation d'une liste numérotée se fait en cliquant sur le logo   . 

L'incrémentation se fait à chaque passage à la ligne. Pour quitter la liste, il suffit de 
recliquer sur le logo.
Passons aux trois paramètres à gauche, qui proposent des menus déroulants.
La taille des caractères est réglable entre 8 et 288 points :
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La police se choisit parmi un nombre important de types :

Mais elles sont insuffisantes pour couvrir tous les besoins typographiques français. En 
particulier, aucune police ne propose des lettres majuscules accentuées. On contournera 
cette difficulté en copiant un caractère spécial dans éditeur de texte tel que Word et de le 
coller sous Maple. On obtient ainsi : Á, Ç, É, È, Ê, etc..
Enfin, le menu déroulant de gauche sert à formater les paragraphes (préfixe P) et les 
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caractères (préfixe C). Il est fort sollicité en pratique dans la mesure où il va peaufiner la 
présentation de la feuille de travail.
Pour l'essentiel, les préfixes P permettent :

d'insérer un titre au début du worksheet avec P Title.
d'insérer le nom de l'auteur avec P Author.
de former plusieurs types de listes (P Bullet Item/pastilles, P Dash Item/tirets, P
Ordered List 1, 2, 3, 4, 5 /listes numérotées, jusqu'à 5 niveaux de profondeur). Pour 
les listes à pastilles et les listes numérotées simples, on a vu qu'il existait des boutons
dédiés dans la barre contextuelle.
d'obtenir des titres de sections, de sous-sections, de sous-sous sections et de sous-
sous-sous sections (P Heading 1, 2, 3 et 4). Il est préférable de ne pas les utiliser dans
le fil d'un texte, mais de structurer sa feuille de travail en créant des sections et sous-
sections à l'aide de Insert → Section ou Subsection dans la barre de menu (voir plus 
haut).

D'autres options, plus spécifiques, sont proposées et on laisse au lecteur le soin de les 
explorer. Un dernier mot au sujet des formatages avec préfixe P : Maple propose des 
caractéristiques par défaut qui peuvent plaire ou déplaire. Dans ce dernier cas, rien 
n'interdit de modifier le paramétrage. Par exemple, on peut préférer un titre dans une autre
police de caractères que Times New Roman et, de surcroît, le vouloir en rouge vif. Il suffit
de le sélectionner puis d'invoquer les menus adéquats. On aura ainsi :

Dans le même ordre d'idée, on modifiera l'allure du nom de l'auteur; on mettra au point un
patron pour dater la feuille de travail; etc..
Quant à eux, les préfixes C offrent de nombreuses possibilités typographiques. Le tableau 
suivant montre l'apparence des caractères suivant l'option choisie :
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A titre d'exemple d'utilisation, quand on veut insérer dans le texte des expressions ayant 
l'allure d'inputs, il suffit de la taper puis de la surligner enfin de sélectionner C Maple 
Input. Pour continuer d'écrire en mode texte courant, il faudra rebasculer en C Text, ce 
qu'on fait rapidement par le raccourci Ctrl+t.

Insertion d'expressions mathématiques
Revenons aux problèmes généraux de rédaction d'un texte. Maple étant un logiciel pour 
faire des mathématiques, les commentaires insérés dans la feuille de travail doivent le plus
souvent intégrer des expressions mathématiques. Il faut admettre que la gestion par Maple
du mixage texte-équations n'est pas très pratique parce qu'elle oblige à manipuler trop 
fréquemment la souris pendant la frappe.
La méthode classique consiste cliquer sur le bouton Math (  ) du menu contextuel 

en cours de frappe. On bascule alors dans le mode de saisie des expressions 
mathématiques à l'intérieur du mode texte. A la fin de la saisie de l'expression, on clique 
sur le bouton Text ( ) pour revenir au mode de saisie d'un texte pur. Ainsi, dans 

l'exemple suivant :
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il a fallu procéder aux manipulations suivantes :
Saisir en mode  "La dérivée de la fonction définie par ";

Cliquer sur ;

Frapper "f(x)=a x^4+b x^2+c ";
Cliquer sur  et saisir "est";

Cliquer sur ;

Frapper "f ' (x)=4 a x^3+2 b x";
Revenir au mode  pour taper le point terminal.

C'est fastidieux, d'autant plus qu'il faut connaître un certain nombre de règles permettant 
de taper en mode Text des expressions mathématiques qui deviendront esthétiques en 
mode Math. Par exemples, taper "accent circonflexe + espace" pour obtenir un exposant. 
Ceci étant, il existe deux astuces pour accélérer la saisie.
En premier lieu, il existe un raccourci clavier pour la bascule du mode Math vers le mode 
Text, soit Ctrl+t. Inversement, la bascule du mode Text vers le mode Math se fait par 
Ctrl+r.
En second lieu, les palettes Expressions et Matrix donnent des patrons commodes pour 
former des expressions fréquentes : intégrales, sommes, dérivées, racines, etc, et, bien 
entendu, des matrices. En cliquant sur un bouton, il y a bascule automatique dans le mode 
Math. Ce n'est pas le cas pour les autres palettes, mais leur exploration minutieuse vaut le 
temps qu'on y consacre car on y trouve une foule de symboles mathématiques 
difficilement accessibles autrement : les flèches; les lettres grecques; les opérateurs tels 
que d , c  , W; les signes de relation tels que x , 2 , 3, R , % ; les signes de 
négation comme s ; les notations d'ensemble comme ;, <, =, C. Il reste que, jusqu'à sa 
version 12, Maple souffre de lacunes évidentes : on ne peut pas obtenir un symbole 
agréable ayant à la fois un exposant et un indice; la notation newtonienne de la dérivée est
peu lisible puisque le "prime" ne peut être écrit qu'avec l'apostrophe du clavier; pas de 
dérivée première exprimée par un point sur le nom symbolique d'une fonction.
Il existe une autre méthode pour obtenir une expression mathématique dans le fil du texte,
consistant à écrire en mode texte une instruction Maple exactement comme elle 
aurait été écrite en mode Maple Input. Considérons par exemple l'énoncé :
La dérivée première de la fonction définie par f(x)=a*x^4+b*x^2+c est diff(f(x),x)=4*a*

x^3+2*b*x
Sélectionnons tout d'abord avec le curseur l'expression f(x)=a*x^4+b*x^2+c, puis, dans le
menu Format, sélectionnons Convert to → 2-D Math, alors on obtient le nouvel affichage 
: f x = a x4

Cb x2
Cc.

De la même manière, l'expression diff(f(x),x)=4*a*x^3+2*b*x se transforme en 
d
dx

 f x = 4 a x3C2 b x. Ainsi, la phrase de départ devient après deux manipulations :

La dérivée première de la fonction définie par f x = a x4
Cb x2

Cc est 
d
dx

 f x = 4 a x3C2 b x

A l'usage, l'appel fréquent à Convert to→2-D Math se révèle fastidieux. Il y a 
heureusement un moyen d'aller plus vite en sélectionnant une expression et en cliquant 
droit sur elle pour faire apparaître un menu contextuel. Il suffit de sélectionner Convert to 
→ 2-D Math pour que la transformation s'opère.
Quand une expression a été validée mais se révèle insuffisante voire fautive, il est possible
de la corriger en sélectionnant l'expression avec le curseur puis en la remaniant dans la 
barre contextuelle qui apparaît sous la barre d'outils.
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OOOO OOOO 

Il est clair que l'écriture de telles expressions mathématiques dépend de la syntaxe retenue
par Maple pour rédiger des inputs valides. Toute incorrection syntaxique est sanctionnée 
par l'affichage d'un message d'erreur qui oblige parfois à reprendre toute la rédaction de 
l'expression non sans avoir au préalable réfléchi sur le moyen d'éviter à nouveau une 
déconvenue.
Si une expression est validée mais se révèle insuffisante voire fautive, il est possible de la 
corriger en sélectionnant l'expression avec le curseur puis en la remaniant dans la barre 
contextuelle qui apparaît sous la barre d'outils.
Une façon similaire de procéder - plus longue, mais assez fiable - consiste à écrire en 
Maple Input l'expression mathématique, la valider (par un point-virgule) et récupérer 
l'écho en le copiant puis en le collant dans le texte : 

f(x)=a*x^4+b*x^2+c;

f x = a x4
Cb x2

Cc

Après avoir copié la réponse (Ctrl+C), on place le curseur après le début de texte : "Soit la
fonction définie par" et on colle par Ctrl+V le contenu du presse-papier. On obtient :  

Soit la fonction définie par f x = a x4
Cb x2

Cc 

Conclusion
Ce chapitre, consacré à l'éditeur de texte Maple, est trop souvent absent des manuels. La pratique
montre pourtant qu'une véritable feuille de travail n'est pas une succession de commandes 
informatiques car ses lecteurs se perdent très vite dans les méandres d'un raisonnement non 
documenté. Sans compter que l'auteur lui même a bien du mal à se repérer quand il reprend un 
travail après quelque temps. Il est essentiel de structurer tout worksheet et d'insérer des 
explications. La manière de bien s'y prendre a été exposée dans les sections. Pour autant, il s'agit 
de conseils incontournables basiques qui ne prétendent pas à l'exhaustivité mais suffisantes pour
obtenir un résultat satisfaisant. D'autres techniques relatives à la mise en page et la typographie 
sont disponibles et il n'est pas sans intérêt d'explorer certaines pistes, par exemple Insert→Image
(que nous avons utilisé pour notre part à hautes doses dans ce chapitre), Insert→Canvas, 
Insert→Object, Insert→Table, etc..
Il y a un conseil majeur qui ne figure pas dans les sections du chapitre et qu'on a réservé à la 
conclusion tant il est important. Maple n'est pas un logiciel de tout repos et réserve des surprises 
désagréables à l'usage. Des crashs intempestifs se produisent parfois et les pertes définitives de 
contenu se révèlent alors insupportables. D'où la règle prudentielle : sauvegarder souvent son 
travail en cours (Fichier→Save ou le raccourci bien connu Ctrl+s) et ne pas hésiter à archiver 
en double sa session de travail même si le worksheet n'est pas achevé. Ces précautions 
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élémentaires permettent d'éviter bien des déconvenues.
Les trois chapitres qui suivent donnent des exemples de worksheet type. Ils ont été conçus 
suivant les règles basiques données dans ce chapitre et en adoptant le paramétrage conseillé du 
mode Worksheet. En recopiant à l'identique les inputs, le lecteur aura donc sur son écran les 
mêmes sorties.
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